MobileTechReview.com logo
MobileTechReview News, Reviews and Forums
Phone Notebooks & Tablets Gaming Gadgets iPhone & iPad Video Reviews


General Discussions >> Ask Us!

Pages: 1
camry
junior member


Reged: 08/13/04
Posts: 2
Charging Tungsten E
      #14382 - 08/13/04 05:44 PM

I just bought a Tungsten E and after charging, I unplugged it the screen will go blank, like it had hang.I only charged it for an hour. Sometimes I had to do a soft reset only the screen will work again.

Is this normal for this model?
Thanks


Post Extras: Print Post   Remind Me!   Notify Moderator  
LisaGModerator
Head Honcho
****

Reged: 07/11/02
Posts: 8348
Loc: Texas
Re: Charging Tungsten E [Re: camry]
      #14387 - 08/13/04 06:45 PM

No, that's not normal.

--------------------
Lisa Gade
Editor in Chief, MobileTechReview


Post Extras: Print Post   Remind Me!   Notify Moderator  
Tanker_Bob
PDA Addict
*****

Reged: 11/24/03
Posts: 245
Loc: N. Virginia
Re: Charging Tungsten E [Re: camry]
      #14434 - 08/15/04 11:19 PM

You should charge it for four hours the first time. It should work for some time after an hour charge, though. Are you sure it actually charged (e.g., was the outlet hot, etc.)?

--------------------
Regards,
Tanker Bob
Tanker Bob's Handheld Computing Page
Reviewer at MobileTechReview


Post Extras: Print Post   Remind Me!   Notify Moderator  
camry
junior member


Reged: 08/13/04
Posts: 2
Re: Charging Tungsten E [Re: Tanker_Bob]
      #14642 - 08/21/04 02:07 PM

The first day when I bought it, I charged the whole night like 6 hrs. Then when I switch it on the screen went blank. I did a soft reset and it still could not work. I thought that my screen protector was the source of the problem which may triggered it to short circuit. So I peel it off it still went blank. After a few trys, I charged it for less than an hour, it will work. I had been using it for a week now and it is still the charging of the battery that is giving me the problem. If it will go blank on the screen, I would reset it a couple of times and than switch it on and off. After a couple of trys the screen will work again. The design of this unit was that when I recharged there is no light to indicate whether it is working but when I switch it to the home menu the battery icon will show a lighting in the centre of the battery icon. This Tungsten E is a wonderful unit but its the charging which is giving me this problem.

My unit is made in China. Does all palm manufactured in China?

Regards,
camry


Post Extras: Print Post   Remind Me!   Notify Moderator  
Tanker_Bob
PDA Addict
*****

Reged: 11/24/03
Posts: 245
Loc: N. Virginia
Re: Charging Tungsten E [Re: camry]
      #14683 - 08/23/04 01:02 AM

If you have access, try charging it with another cable or cradle. Either way, it definitely sounds like a bad connection somewhere and you should probably exchange the PDA.

--------------------
Regards,
Tanker Bob
Tanker Bob's Handheld Computing Page
Reviewer at MobileTechReview


Post Extras: Print Post   Remind Me!   Notify Moderator  
Pages: 1



Extra information
0 registered and 4 anonymous users are browsing this forum.

Moderator:  Greg, LisaG, Jacob_Spindel, Tong Zhang 

Print Topic

Forum Permissions
      You cannot start new topics
      You cannot reply to topics
      HTML is disabled
      UBBCode is enabled

Rating:
Topic views: 3536

Rate this topic

Jump to

Contact the Folks at MobileTechReview.com | Privacy statement Go to mobiletechreview.com homepage

Powered by UBB.threads™ 6.5.5