MobileTechReview.com logo
MobileTechReview News, Reviews and Forums
Phone Notebooks & Tablets Gaming Gadgets iPhone & iPad Video Reviews


General Discussions >> Ask Us!

Pages: 1
Captain_Chuck
junior member


Reged: 02/17/08
Posts: 3
Loc: New Orleans
Please somebody help me!!!
      #29645 - 02/17/08 09:35 PM

I bought a brand new Eten Glofiish X800 and it will not make phone calls on the Cingular/AT&T network. I can send and receive text mess. and the internet browser works as well. When I make a phone call to or from the phone it rings through but when you answer it beeps twice and disconnects. I have been searching for 2 days trying to find a resolution to this problem because Eten tech support is basically nonexistent. If anyone can help me I would greatly appreciate it. Thanks.

Chuck


Post Extras: Print Post   Remind Me!   Notify Moderator  
LisaGModerator
Head Honcho
****

Reged: 07/11/02
Posts: 8285
Loc: Texas
Re: Please somebody help me!!! [Re: Captain_Chuck]
      #29646 - 02/17/08 10:55 PM

I use the X800 I reviewed for our site daily on AT&T and it doesn't drop calls on pick up (or otherwise). The double-beep sound indicates a dropped call. I think you may have received a defective unit. Can you get replacement?

My only other guess would be a really old 3G SIM. If you have a pre-3G or early 3G SIM (more than a year old) you might try getting it replaced at your local AT&T corporate store to see if that fixes the problem first. If you're not in a 3G coverage area, this probably won't make a difference. If you're not in a 3G coverage area go to phone settings and try changing the band to GSM only instead of the default "auto" under the "others" tab.

--------------------
Lisa Gade
Editor in Chief, MobileTechReview


Post Extras: Print Post   Remind Me!   Notify Moderator  
Captain_Chuck
junior member


Reged: 02/17/08
Posts: 3
Loc: New Orleans
Re: Please somebody help me!!! [Re: LisaG]
      #29647 - 02/17/08 11:05 PM

Thank you for your response Lisa. I will be exchanging the phone because of a dead pixel and I, like you, was also thinking it may be my older 3G sim. I am going to get another phone as well as a new 3G sim card and hopefully that will solve my problem.

I also was trying to do the 402 update with the windows xp rom updater. It goes into usb bootloader mode but the program keeps saying that it is not compatible with my os...???

I have tried 6 times with no luck. Any ideas?

Thanks again.

Chuck


Post Extras: Print Post   Remind Me!   Notify Moderator  
LisaGModerator
Head Honcho
****

Reged: 07/11/02
Posts: 8285
Loc: Texas
Re: Please somebody help me!!! [Re: Captain_Chuck]
      #29663 - 02/19/08 10:06 PM

Yikes, I haven't gotten that error using E-TEN ROM updaters before on previous models. Though with the X800, mine came with the most recent ROM so I haven't had to upgrade that particular model.

--------------------
Lisa Gade
Editor in Chief, MobileTechReview


Post Extras: Print Post   Remind Me!   Notify Moderator  
Captain_Chuck
junior member


Reged: 02/17/08
Posts: 3
Loc: New Orleans
Re: Please somebody help me!!! [Re: LisaG]
      #29670 - 02/20/08 08:41 PM

I figured out the ROM updater and got it up to version 402. Now here is something even more strange....My phone works in neighboring cities but not in mine!!! I traveled to my girlfriends house about 65 miles from my own and the phone worked fine. When I got back to my town (which is actually larger than hers) it stopped working and started the ring once then beep twice then nothing thing again. I am stumped. I am now thinking of switching carriers. I have AT&T now but the service has been getting worse instead of better. Thanks for your assistance Lisa. If you think of anything else I can try please let me know.

Take care,
Chuck


Post Extras: Print Post   Remind Me!   Notify Moderator  
Pages: 1



Extra information
0 registered and 4 anonymous users are browsing this forum.

Moderator:  Greg, LisaG, Jacob_Spindel, Tong Zhang 

Print Topic

Forum Permissions
      You cannot start new topics
      You cannot reply to topics
      HTML is disabled
      UBBCode is enabled

Rating:
Topic views: 5036

Rate this topic

Jump to

Contact the Folks at MobileTechReview.com | Privacy statement Go to mobiletechreview.com homepage

Powered by UBB.threads™ 6.5.5