MobileTechReview News, Reviews and Forums

Wireless and Mobile Phones >> Android Phones and Tablets


Reged: 11/17/06
Posts: 29
Re: Samsung Note 10.1 2014
      02/18/14 10:20 PM


Time for two more question?

I just read a review on the Best Buy website in reference to the Note 12.2 that Android 4.4.2. Reviewer says he was unable to transfer apps and data from apps to the micro-SD card.

Is that a potential problem on the Note 10.1 2014 if a user updates Android to its latest edition? Assuming a user can update the system.

I've been an iPad user since the original iPad. Apple seems to update its iOS frequently, and makes the updates available on its old iPads. It seems to me that Android tablets don't get the same type of support with updates of the system. Instead, each time a new version of Android is released, the newest Android operating systems seems to be only available on the latest tablets. For example, I haven't read anywhere about Note 8 owners updating from 4.2 to 4.3.

Should I be concerned (as a wanna-be Note 10.1 or 12.2 owner) that Android tablets don't receive the same updates like iPads do?

Post Extras Print Post   Remind Me!     Notify Moderator

Entire topic
Subject Posted by Posted on
* Samsung Note 10.1 2014 Armanius 01/27/14 05:27 PM
. * * Re: Samsung Note 10.1 2014 LisaGModerator   01/31/14 03:25 PM
. * * Re: Samsung Note 10.1 2014 Armanius   02/14/14 06:04 PM
. * * Re: Samsung Note 10.1 2014 LisaGModerator   02/16/14 03:33 PM
. * * Re: Samsung Note 10.1 2014 Armanius   02/18/14 10:20 PM
. * * Re: Samsung Note 10.1 2014 LisaGModerator   02/19/14 05:03 AM
. * * Re: Samsung Note 10.1 2014 Armanius   02/20/14 05:26 AM

Extra information
0 registered and 1 anonymous users are browsing this forum.

Moderator:  Tong Zhang, LisaG, Jacob_Spindel 

Forum Permissions
      You cannot start new topics
      You cannot reply to topics
      HTML is disabled
      UBBCode is enabled

Thread views: 7445

Rate this thread

Jump to

Contact the Folks at | Privacy statement Go to homepage

Powered by UBB.threads™ 6.5.5